Creo Parametric Primer
Education Editions
Contents

Contents ............................................................................................................. 3
Introduction ........................................................................................................ 5
Understanding the Creo Parametric interface ................................................. 6
What’s new for existing users of Creo Elements/Pro ....................................... 8
Working directories and saving your work ..................................................... 9
  Working Directory Theory ............................................................................. 9
  Opening Files ................................................................................................. 10
  Saving Files .................................................................................................. 10
Procedure - Modeling the cube corner ......................................................... 11
  Step 1: Set working directory and create a new part ................................... 12
  Step 2: Start an Extrude ............................................................................... 14
  Step 3: Create a sketch to define the cube section ...................................... 15
  Step 4: Complete the Extrude for the corner block .................................... 18
  Step 5: Extrude first hole .......................................................................... 22
  Step 6: Extrude second hole ........................................................................ 26
  Step 7: Hole using a feature ....................................................................... 31
  Step 8: Corner rounds ................................................................................ 35
  Step 9: Chamfer holes ............................................................................... 38
Procedure - Modeling the strut ...................................................................... 41
  Step 1: Set working directory and create a new part ................................... 42
  Step 2: Start an Extrude ............................................................................... 44
  Step 3: Sketch the peg diameter .................................................................. 44
  Step 4: Complete the Extrude for the peg solid ........................................ 46
  Step 4: Extrude shoulder solid ................................................................... 47
  Step 5: Revolve an arc to thin the center of the strut .................................. 50
  Step 6: Round corners ............................................................................... 55
  Step 7: Chamfer strut ends ........................................................................ 56
Procedure – Assembly .................................................................................... 57
  Step 1: Set working directory and start a new assembly .............................. 58
  Step 2: Adding the first component to the assembly .................................... 60
  Step 3: Add the first strut to the assembly ................................................... 63
  Step 4: Applying color textures to parts ...................................................... 68
  Step 5: Adding more struts ........................................................................ 70
Procedure - Rendering ................................................................................... 74
  Step 1: Render toolbar and apply a scene .................................................... 74
Step 2: Draft render ................................................................. 78
Step 3: Adding perspective ...................................................... 79
Step 4: Render setup ............................................................... 80
Step 5: Final render ................................................................. 81
Procedure - Engineering drawing ............................................. 82
   Step 1: Set working directory and open cube corner .................. 83
   Step 2: New engineering drawing ......................................... 84
   Step 3: Changing the drawing scale ....................................... 87
   Step 4: Moving views .......................................................... 88
   Step 5: Adding dimensions .................................................. 89
   Step 6: Adding annotations ................................................... 92
Accreditation/optional extension task ....................................... 94
Module 1

Introduction

This primer will introduce you to the modeling, visualization and design tools in Creo Parametric.

Creo Parametric is a leading 3D design program, used by many of the top product development companies in the world.

You will be taught how to use Creo Parametric to model two components for a construction kit - a cube and a strut.
You will then be shown how to put these together to form an assembly.
Module 2
Understanding the Creo Parametric interface

The Main Creo Parametric interface looks like this.

Main Interface Theory
The Creo Parametric user interface is easy to navigate with the key tools for a particular task contained in the ribbon across the top of the graphics area. Key elements of the main interface include:

Quick Access Toolbar — Contains commonly used tools and functions.

Ribbon Tabs — A set of tabs across the top of the interface. The active tab displays a set of tools in the ribbon immediately below. Here the View tab is active.
Graphics Area — The working area of Creo Parametric in which you view, create, and modify models such as parts, assemblies, and drawings.

Message Area — The message area provides you with prompts, feedback, and messages from Creo Parametric. Messages are logged and can be scrolled or the message window dragged to display more lines.

Dashboard — locked at the top of the graphics area, the Dashboard appears when you create or edit a feature.

- The Dashboard provides you with controls, inputs, status, and guidance for carrying out a task, such as creating or editing a feature. Changes are immediately visible in the graphics area.
- Tabs along the bottom of the Dashboard provide additional feature options.
- Dashboard icons on the left include feature controls while the Pause, Preview, Complete Feature, and Cancel Feature options are grouped right of the center.

- Dialog Boxes — Content-sensitive windows that appear, displaying and prompting you for information.
• **Menu Manager** — A cascading menu that appears on the far right during the use of certain functions and modes within Creo Parametric. You select options working from top to bottom in this menu; however, clicking “Done” works from bottom to top. Bold menu options will be automatically selected if the middle mouse button is clicked.

---

**What’s new for users of Creo Elements/Pro**

To help existing users of Creo Elements/Pro and Pro|ENGINEER upgrade to Creo Parametric 1.0 here is a list of the key changes:

- Tabbed ribbon menus with 90% of the tools instantly available.
- Customizable ribbon interface.
- The new Command Search tool lets you type a command and see a filtered list of tools. When you cursor over an item in the list, Creo locates and highlights the command in the ribbon.
- New “Shading with Edges” display type.
- Starting a feature like extrude lets you select the sketch plane without seeing the sketch dialog box. Much simpler and now the quickest (CAD program) on the draw!
- While sketching, holding down the ALT key lets you create references on-the-fly without interrupting the sketch tool.
- Construction mode in sketcher.
- The new Center Rectangle tools lets you sketch a rectangle form its center.
- Enhanced geometry colors to help visualization and selection.
- Freestyle is a new subdivision modeler in Creo Parametric. Freestyle is similar to Warp but much more powerful and very easy to use. Take a look at the vacuum cleaner demo on YouTube.
- Dynamic Edit - Direct access to features and parameters with real time regeneration.
- Automatic addition (protrusion) or removal (cut) of material when creating Extrude or Revolve features.
- Extrude with taper or draft applied to the side surfaces of the extruded geometry.
- New, easy to use Corner Chamfer tool.
- Single sweep command combines variable section and simple sweep tools.
- Single helical sweep tool now offers variable section and variable pitch.
- Creo Parametric will open native Solidworks, Inventor and Solid Edge models making it easy to reuse legacy data when upgrading to Creo.
Working directories and saving your work

The Working Directory is the location for opening files from and saving new files to.

Setting your Working Directory:

- Creo Parametric is started in a default working directory.
- A working directory is the folder you open files from and save files to.
- The working directory is set before every session. When you exit Creo, it does not remember the working directory for the next session.

Open Files - The File Open dialog box looks first in the working directory.

Save Files - Files are saved to the folder they were opened from, this is not always the working directory.

There are three methods to set your working directory, use the method you are most comfortable with:

- **From the Home menu** - When Creo Parametric first opens, Click **Select Working Directory** from the Data group of the Home tab. Browse to locate the directory that is to be the working directory. Select it and click OK. *This is the easiest and most straightforward method.*

- **From the File menu** – If the Home tab is not available - Click **File > Manage Session > Select Working Directory**. Browse to locate the directory that is to be the new working directory, select it and click OK.

- **From the Creo Parametric Folder Tree or Browser** - Right-click the folder that is to be the new working directory and select **Set Working Directory** from the pop-up menu.
From the Creo Parametric File Open dialog box - Right-click the folder that is to be the new working directory and select Set Working Directory from the pop-up menu.

You can browse directly to the working directory at any time by selecting Working Directory in the folder view of the Navigator panel on the left of the Creo window.

Opening Files

After you have set your working directory, you will see the files in that folder each time you click Open in Creo Parametric.

You can use any of the following methods to open a file:

- Click File > Open from the main menu, click Open from the Quick Access toolbar or click Open from the Home tab. Then, in the File Open dialog box, you either double-click the file you want to open or select the file and click Open.
- Browse to the desired folder using the Navigator to display its contents in the browser. Then, you either double-click the file you want to open or right-click the file in the browser and select Open from the pop-up menu.
- Drag a file from the browser into the graphics area.

The File Open dialog box is the equivalent of the Navigator and Browser combination in the main interface.

Saving Files

By default, files are saved to the folder they were opened from. A new part, assembly, or drawing will be saved to the folder that is active when you click OK from the Save Object dialog box.

You can use any of the following methods to save a file:

- Click File > Save from the File menu.
- Click Save from the Quick Access toolbar.
- Use the CTRL + S keyboard shortcut.

What have you learned about?

- The layout of Creo Parametric’s user interface
- Interface items such as the Dashboard, dialog boxes, and the ribbon interface
- Working directories and file management
Procedure - Modeling the corner cube

Scenario

This section will teach you how to model a cube shaped corner block for a construction kit.

You will start by creating a new part, add a square sketch, and use this to extrude the cube shape. Extruded circles will be used to create two of the holes and a hole feature will be used for the third hole.

Rounds on the outer corners and chamfers on the holes will complete the model.
Step 1: Set working directory and create a new part

1. If necessary, start Creo Parametric.

2. Setting the working directory:

   - Click **Select Working Directory** from the **Data** group of the **Home** tab.
   - In the Select Working Directory dialog box, browse into the folder where you want to store your construction kit components. We suggest that you create a new folder (right-click and select **New Folder from the pop-up menu**) for each project you work on.
   - After you have browsed into the working directory folder, click **OK** to set that folder as your working directory.

   ![The Corner Cube part you create will be saved to and opened from this “working directory”](image)

3. Creating the new corner cube part model:

   - From the Quick Access toolbar or **Home** tab, click **New**.
   - In the New dialog box, notice the default object **Type** is **Part** and Sub-type is **Solid**, these are the correct options for creating a solid part.
   - Type **CORNER_CUBE** in the **Name** field and click **OK**.

   ![You cannot use spaces in filenames so use underscores or hyphens instead.](image)
4. Changing the display of datum features:
In the Graphics toolbar at the top of the graphics area, disable the display of all datum features except datum planes.

Think of datum planes as the framework your model will be built on.
Datum planes have a front or positive surface and back or negative surface.
The frame showing the placement of each datum plane is colored brown when viewed from the front (positive side) and gray when viewed from the rear (negative) side.

What have you learned about?

- Setting working directories and starting new parts
- Controlling the display of datum features
- Datum plane theory
Step 2: Start an Extrude

The easiest way to start creating solid geometry in Creo Parametric is to begin a 3D feature, in this case an extrude, then select the sketch plane. Extrude is just one of the “sketch based” features in Creo Parametric.

You will start an Extrude then select datum plane FRONT as your sketching plane.

1. Starting an Extrude (sketch based) feature and defining the sketch plane:
   - Start the Extrude tool from the Shapes group of the Model tab.

   While using Creo Parametric, keep an eye on the prompt line at the bottom of the screen. There you will see messages telling you what Creo is doing, if there is a problem or what you need to do next. In this case you are being guided to select the sketch plane

   Select a sketch. (If an internal sketch is preferred, the “Define” option can be found in the Placement panel.)

   - In the model tree or the graphics area, select datum plane FRONT.

   The Sketch tab will open and you will be able to start sketching. Two “Reference” lines will be visible on the Front datum plane.

   A sketch needs a minimum of two Reference lines to locate the geometry you create. In this case Creo Parametric has created these automatically based on the other two datum planes.

What have you learned about?

- Starting an Extrude (sketch based) feature.
- Selecting a sketch plane.
- The Ribbon interface workflow.
Step 3: Create a sketch to define the shape of the cube

A 2D, 30 mm square will be sketched on datum plane FRONT. The square will be drawn symmetrical about the intersection of the reference lines using a Center Rectangle tool. You will add an equal length constraint on two adjacent sides of the square.

1. Toggle off the display of datum planes:
   - In the Graphics toolbar, disable the display of all datum features.

2. Sketching the rectangle:
   - In the Sketch tab, select Center Rectangle from the Rectangle types drop-down menu.
   - In the Graphics toolbar, click Sketch View to reorient the sketch plane parallel to the screen.

The model space will rotate until the sketch plane is parallel to the computer screen.
   - Move the cursor over the intersection of the two reference lines X1, when the cursor snaps to the intersection, click to locate the center of the rectangle.
   - Move the cursor diagonally and click X2 to locate a corner of the rectangle.
   - Middle-click in the graphics area to deselect the rectangle tool.
Skeches are controlled by two types of parametric constraint.

**Dimension constraints** allow you to alter sizes. Later you will use dimensions to define the size of this rectangle.

**Geometric constraints** including; equal length, parallelism, perpendicular, coincident, and so on. Creo has already applied many of these while you were sketching the square; to keep lines vertical/horizontal and make lines pass through the origin. Next, to change this rectangle to a square, you will apply an equal length constraining.

3. Adding an “equal length” sketcher constraint:

You will add an equal length geometric constraint between two adjacent sides of the rectangle to make it a square. Creo Parametric is smart enough to remove one of the blue-gray (weak) dimensions to avoid over constraining the sketch.

- Click X1 to select the top horizontal line in the rectangle. The line should change color to **green** to show it is selected.
- Press and hold **CTRL** on the keyboard, then click X2 to add the vertical line to the selection. This line will also change color to **green**.
- With both lines selected, right-click and select **Equal** from the pop-up menu (shown as X3).

Notice that a pair of L1 constraints will appear next to the selected lines.
There should now be just one dimension on the sketch. This is called a “weak” dimension and it is displayed in a blue-gray color. Sketch dimensions are “parametric” meaning when you change them the geometry will change to match the new value. You will change the dimension to 30 and lock it.

4. Changing a dimension to 30:
   - Move the cursor over the dimension value at X1 and double-click.
   - Type the new value of 30 and then press ENTER.

The size of the square will change according to the new dimension value. You have just seen parametric control in action.

If necessary, click Refit from the Graphics toolbar. This will refit the sketch in the graphics area.

The position and size of sketch lines are controlled by a combination of dimension constraints and geometric constraints.

Notice that the dimension changed to a purple color, showing that it is now a strong dimension.

5. Click OK from the Close group of the Sketch tab to complete the sketch and return to the Extrude dashboard.

What have you learned about?

- Creating sketch geometry - center lines and center rectangles.
- Geometric constraints – overview, apply equal length
- Dimension constraints, weak, strong, locked.
- Viewing the model – default, flat sketch view, spin.
- Datum plane - visibility.
- Dashboard interface.
Step 4: Complete the Extrude for the corner block

You will now edit the depth of the Extrude to be 30, extruding equally in both directions from the sketch plane. Extruding equally in both directions from the sketch plane means that the datum planes are at the center of the cube; this will be helpful when locating the holes later in this exercise. Extrude is a sketch based feature and this example uses an "Internal" sketch.

1. If necessary, use the Graphics toolbar to disable the display of all datum features.

2. Reorient the model to its default orientation:
   - Press **CTRL + D** (on the keyboard, hold down the **CTRL** key and press **D**).
     
     The model will reorient to the 3D view named Standard Orientation. This is often referred to as the Default view.

     You will now see a preview of the extruded square sketch.

You can change how the extrude is defined either in the dashboard or on the model. Every parameter that defines the Extrude feature can be accessed from the dashboard. After a feature is complete, you can use Edit Definition to re-open the dashboard and edit the feature.
3. Making changes to the extrude using the dashboard:

- Click **Blind** and then select **Symmetric** from the depth drop-down menu (shown as X1).
- Click in the depth field X2, type 30 and press **ENTER**.
- Click **Complete Feature** from the dashboard.

6. Saving your work

- In the Quick Access toolbar, click **Save** to save your model.
- In the **Save Object** dialog, click **OK** to specify that the model will be saved to your working directory.

If the extrude dashboard mysteriously closes before intended, you probably middle mouse clicked. Engineers use many shortcuts to speed up their work and middle click is the shortcut to select **Complete Feature** and close the dashboard!

- If you need to re-open the dashboard, right-click on **Extrude 1** in the dashboard and select **Edit Definition** from the pop-up menu.

What have you learned?

- Viewing the model – default, spin.
- Datum plane - visibility.
- Sketch based feature – Extrude adding material (protrusion), symmetrical.
- Dashboard to store and change feature parameters
- Model area to change feature parameters
- Edit Definition to re-open and change existing features.
Dynamic Viewing

The orientation of your model within the graphics area is easily controlled using the mouse and the Graphics toolbar.

3D mode

- Spin
- Pan
- Zoom
- Turn

2D and 3D mode

Hold down the key and roll the mouse.

- Zoom
- Fine Zoom +
- Course Zoom +

2D mode

- Pan
- Zoom

It is possible to ‘lose’ the model from the graphics area by spinning or panning the model completely out of the display. If your model ever disappears from the window, click Refit from the Graphics toolbar.
The Graphics toolbar at the top of the graphics area controls how the model appears in the graphics area.

Experiment with the options to see the effect they have on the appearance of the model.
Step 5: Extrude the first hole

Instead of creating material, the extrude tool can also be used to remove material, in this case an extruded cut that is shaped like a circle. This extrude feature will be created by sketching an 8 mm diameter circle on the front face of the cube. The extrude will remove material and intersect the entire cube.

1. If necessary, use the Graphics toolbar to disable the display of all datum features.

2. Starting an Extrude (sketch based) feature and defining the sketch plane:
   • Start the Extrude tool from the Shapes group of the Model tab.

3. Starting an internal sketch:
   • Press CTRL + D to reorient the model.
   • In the graphics area, click to select the front face of the cube X1, as the sketch plane. The Sketch tab will open and you will be able to start sketching immediately.
   • To make sketching easier while you are learning, click Sketch View from the Graphics toolbar; this will reorient the sketch plane parallel to the computer screen.
4. Sketching a circle:
   • Click Circle from the Sketching group of the Sketch tab.
   • Move the cursor until it snaps to the intersection of the reference lines X1, then click to locate the center of the circle at this intersection.
   • Move the cursor away from the center and click at X2 to complete the circle.
   • Middle-click in the graphics area to deselect the circle tool.
   • Double-click the diameter dimension value X1, then type 8 and press ENTER.

The circle will resize and the dimension will change color to show it is now strong.

Click OK from the Close group of the Sketch tab to complete the sketch and return to the Extrude dashboard.

5. Reorient the model to its default orientation:
   • Press CTRL + D to reorient the model.

By default, Creo Parametric will display a preview the extruded circle, adding material out, away from the model.
   • Drag the drag handle (small white square) away from the model to add depth to the feature.
   • Drag the drag handle the other direction, into the model to reverse its direction.
Notice that Creo Parametric is smart enough to know that extruding into the model requires material to be removed (a cut).

In the Extrude dashboard at the top of the graphics area, you will see that the Remove Material (X2) icon has been automatically enabled.

4. Making changes to the extrude using the dashboard.

   - Click **Change Depth Direction** (X1) to flip the extrude direction.
   - Click **Remove Material** (X2) to disable it and add material to the model.
   - Click **Change Depth Direction** again (X1).
   - Click **Remove Material** (X2) to re-enable it and remove material from the model.
   - Select **Through All** from the depth drop-down menu, so that the extrude feature will intersect the entire model.
   - Press the middle mouse button and drag to spin the model and see that the extrude feature intersects the entire model.
• In the dashboard, click **Complete Feature** to complete the extrude feature.

5. Saving your work:
   • Press **CTRL + D** to reorient the model.
   • In the Quick Access toolbar, click **Save**.

What have you learned?

• Viewing the model – Default.
• Display of datum.
• Extrude – removing material (cut), changing direction, intersect will all surfaces.
• Internal sketch on a surface.
• Sketcher geometry – Circle, dimension, lock dimension.
• Saving the model
Step 6: Extrude the second hole

You will use the technique used in Step 5, to extrude another 8 mm diameter cut. This time though, the circle will be sketched on the side of the cube.

1. Starting an Extrude feature and defining the sketch plane:

Start the **Extrude** tool from the **Shapes** group of the **Model** tab.

2. If necessary, disable the display of all datum features.

3. Starting an internal sketch:

   • If necessary, press **CTRL + D** to reorient the model.

   • In the graphics area, click to select the side face of the cube **X1**, as the sketch plane.

      The Sketch tab will open, presenting you with all of the sketching tools.

      This time leave the model in default view while sketching the circle.
To easily locate the center of the circle at the center of the cube, you will create another reference from datum plane FRONT.

You could create this reference before sketching by clicking References from the Setup group of the Sketch tab. It can also be created on-the-fly while sketching.

4. Enable the display of datum planes.

5. Creating a reference “on-the-fly”, while sketching a circle:
   - Click Circle from the Sketching group of the Sketch tab.
   - Press and hold the ALT key, while in the graphics area, you move the cursor over datum plane FRONT (X1). When the datum plane pre-highlights in green, click to select it as a sketcher reference.

A new light blue reference line is created coincident with the FRONT datum plane.
• Move the cursor until it snaps to the intersection of both reference lines in the center of the sketch plane and click (X1) to locate the center of the circle.

• Move the cursor away from the center and click at X2 to complete the circle.

• Middle-click in the graphics area to deselect the circle tool.

6. Edit the diameter of the circle:

   • Double click the diameter dimension value X1, then type 8 and press ENTER.

   The circle will resize as soon as you press ENTER.

7. Click OK ✓ from the Close group of the Sketch tab to complete the sketch and return to the Extrude dashboard.

7. Disable the display of all datum features.
8. To flip the direction of the feature, click the small yellow direction arrow (X1).

Notice that when the extrude direction was flipped into the model; Remove Material was automatically enabled (X1).

6. Edit the depth of the extrude to intersect the entire model.
   - Select **Through All** from the depth drop-down menu, so that the extrude feature will intersect the entire model.
   - Spin the model to see that the extrude feature intersects the entire model.
   - In the dashboard, click **Complete Feature**.
7. Saving your work:
   • In the Quick Access toolbar, click Save.

Accepting default names for features is fine for simple models like this. Complex models can have hundreds of features making it difficult to find a particular feature in the model tree to make edits. It is good practice to give key features recognizable names. Features can be renamed when they are being created or by clicking twice on the text in the model tree, making sure to pause between clicks.

What have you learned?
   • Viewing the model – Default, flat onto sketch plane.
   • Renaming feature names.
   • References, specifying references on-the-fly while sketching geometry.
   • Sketcher – Internal sketch, circle, dimension, lock dimension.
   • Extrude – remove material, changing direction, intersect with all surfaces.
   • Saving the model.
Step 7: Use the Hole tool to create the third hole

Creo Parametric’s Hole tool is a “direct” features meaning it does not rely on a sketch to define its shape. The placement of a hole feature can be defined in many different ways. This hole will be placed on the top surface of the cube and then located using two align constraints from datum planes FRONT and RIGHT.

1. Reorient the model to its default orientation:
   • Press CTRL + D to reorient the model.

2. Enable the display of only datum planes.

3. Creating a hole feature:
   • Start the Hole tool from the Engineering group of the Model tab.
   • Notice the Hole dashboard and its hole feature specific options.

   • Click to select the top surface of the model, shown in green.
   • Notice the preview of the hole feature is at the location you selected on the surface.

The square white drag handles control the location of the center, diameter and depth of the hole.

The green diamond shaped offset reference handles control the location of the hole’s center on the green placement surface.
You will drag the green diamonds onto the RIGHT and FRONT datum planes to use these as references for the location of the hole.

4. Locating the hole using offset reference handles:
   - Drag one of the green offset reference handles X1, to datum plane FRONT, when the plane pre-highlights, release the mouse button.
   - Drag the other offset reference handle X2 onto datum plane RIGHT.

It is easy snap a drag handle onto the wrong reference. If this happens, either click Undo or simply drag the handle to the intended reference.

You will now see dimensions between each datum plane and the center of the hole.

To locate the hole at the center of the cube, you could edit both linear dimensions to be zero but a better method is to change the offset references from a dimension value to Align.
• Open the Placement tab from the bottom-left of the dashboard X1.

• In the Offset References section of the tab X2, click Offset from one of the references and select Align from the drop down menu.
• Edit the other Offset reference to also be Align.
• Click on the Placement tab to close it.

Notice that because the center of the hole is now aligned to datum planes FRONT and RIGHT, the offset dimensions have been removed. You will now use the dashboard to define the diameter and depth of the hole.

5. Defining the diameter and depth for the hole in the dashboard:

• Edit the hole diameter X1 to be 8 and press ENTER.
• Select Through All X2 from the depth drop-down menu, so that the hole will intersect the entire model.

You have completed the definition of an 8 mm thru hole; located at the center of the cube.
• Spin the model to see that the hole intersects the entire model.
• Click Complete Feature.

6. Saving your work:
• Click Save.
What have you learned?

- Direct feature – Hole
- Viewing the model – Default
- Hole reference – model surface
- Hole placement - offset from datum planes, change to align.
- Hole dashboard – diameter, depth (intersect with all surfaces).
- Saving the model.
Step 8: Round edges of the cube

The Round feature is a “Direct” type feature applied to edges of a model. You will now add a 5 mm radius round to the twelve outside edges of the cube.

1. Press **CTRL + D** to reorient the model.

2. If necessary, disable the display of all datum features.
   
3. Edit the model display style to be *Hidden Line*:
   
   - In the Graphics toolbar, select **Hidden Line** from the Display Style types drop-down menu.

This display style will make it easier for you to see edges at the back of the model.
4. Start the **Round** tool from the **Engineering** group of the **Model** tab.
   - Notice the Round dashboard and its round feature specific options.

![Round dashboard](image)

5. Defining the radius of the round:
   - In the dashboard, edit the radius **X1** to be **5** and press **ENTER**.

6. Selecting the edges to round:
   - Click to select one of the edges shown in **green**.
   - Press **CTRL** and select the remaining 11 edges shown in **green**.

   ![Selecting edges](image)

   - If you select an edge by accident, keep the CTRL key held down and click the edge again to de-select.

   ![De-selecting edge](image)

   - If you need to re-open the round dashboard, right-click the **Round 1** feature in the model tree, and select **Edit Definition** from the pop-up menu.

7. Click **Complete Feature** to complete the round.

![Complete Feature](image)
8. Changing the display style and saving your work:
   - In the Graphics toolbar, select **Shading with Edges** from the Display Style types drop-down menu.
   - Click **Save** to save your work.

What have you learned?

- Direct feature – Round.
- Round dashboard - radius.
- Selecting edge references – individual, adding more edges.
- Rotating the model.
- Editing model tree entries – Accidental closure of the dashboard
- Saving the model.
Step 9: Chamfer edges of the holes

The Chamfer feature is a “Direct” type feature applied to edges of a model. You will now add 0.5 mm chamfers to the six edges of the holes that intersect the outer surfaces of the cube.

1. Press **CTRL + D** to reorient the model.
2. If necessary, disable the display of all datum features.

3. Start the Chamfer tool from the Engineering group of the Model tab.
   - Notice the Chamfer dashboard and its chamfer feature specific options.

4. Defining the size of the chamfer:
   - In the dashboard, edit the chamfer width $X_1$ to be 0.5 and press **ENTER**.

5. Selecting the edges to chamfer:
   - Click to select one of the edges shown in **green**.
   - Press **CTRL** and select the other two edges shown in **green**.
6. Spinning the model to select more edges:
   - Release the CTRL key.
   - Spin the model to see the three edges that have not been selected.

If you middle-click but do not hold down the middle-mouse to spin the model, the feature will complete with only the first three edges selected and the dashboard will close. To re-open the dashboard and select the remaining edges, right-click Chamfer 1 from the model tree and select Edit Definition from the pop-up menu.

7. Selecting the remaining edges:
   - Press CTRL and select the remaining edges.

8. Click Complete Feature.

9. Spin the model to see the completed chamfer feature.
Until now, you have used only \texttt{CTRL + D} to reorient your model. This time you will select named views from the Graphics toolbar:

10. Click \textbf{Named Views} \textsuperscript{8} from the Graphics toolbar, then scroll down and select \textbf{TRIMETRIC} from the drop-down menu.

11. Click \textbf{Named Views} \textsuperscript{8} and select \textbf{Standard Orientation} from the drop-down menu.

12. Saving your work and closing open windows from the Quick Access toolbar:
   - Click \textbf{Save} \textsuperscript{9} to save your work.
   - Click \textbf{Close Window} \textsuperscript{9} as many times as are required to close any open windows.

\textbf{What have you learned?}

- Direct feature – Chamfer.
- Chamfer dashboard – width (D x D).
- Selecting edge references – individual, adding reference edges.
- Rotating the model.
- Editing model tree entries – Accidental closure of the dashboard
- Saving the model.
Module 2

Procedure - Modeling the strut

Scenario

Connecting the corner cubes will be struts with pegs at each end that fit into the holes in the corner cubes. The kit is based on 100 mm spacing between cube centers so, allowing for clearance in the center of the cubes means the strut will be 90 mm long.

After creating a new part, you will sketch a small circle at the center of the strut and extrude this on both sides of the sketch to form the pegs. A larger circle, also located in the center of the strut, is extruded to form the shouldered section. Finally, a revolved arc cuts material from the strut to create the narrowed center section.
Step 1: Set working directory and create a new part.

If you just completed Module 1 and have not exited from Creo Parametric, tasks 1-3 below do not need to be performed, please skip to task 4.

1. Start Creo Parametric.

2. Click Close Window from the Quick Access toolbar, as many times is necessary to close all open models.

3. Setting the working directory:
   - Click Select Working Directory from the Data group of the Home tab.
   - In the Select Working Directory dialog box, browse into the folder where you saved the Corner Cube model.
   - After you have browsed into the working directory folder, click OK to set that folder as your working directory.

The Strut part you create will be saved to and opened from this “working directory”, the same folder where your Corner Cube was saved.

4. Creating the new strut part model:
   - From the Quick Access toolbar or Home tab, click New.
   - Type STRUT_100 in the Name field and click OK.

You cannot use spaces in filenames so use underscores or hyphens instead.

5. Changing the display of datum features:
   - In the Graphics toolbar, disable the display of all datum features except datum planes.
What have you learned?

- Setting the working directory.
- Create a new part
- Datum display – visibility
Step 2: Start an Extrude

You will start an Extrude choosing datum plane RIGHT as the sketch plane.

1. Starting an Extrude feature and defining the sketch plane:
   - Start the Extrude tool from the Shapes group.
   - In the model tree or graphics area, select datum plane RIGHT.

The Sketch tab will open and you will be able to start sketching. Notice the two “Reference” lines will be visible datum plane Right

What have you learned?

- Starting an extrude feature.
- Selecting a sketch plane.
- Ribbon menu workflow.

Step 3: Create a sketch to define the peg diameter

A 2D, 8 mm diameter circle will be sketched on datum plane RIGHT. The center of the circle will be located at the intersection of the horizontal and vertical sketcher references. This sketch will be created in the 3D view, without reorienting to the 2D sketch view.

1. Sketching a circle:
   - In the Sketch tab, click Center and Point Circle.
   - Move the cursor over the intersection of the two reference lines X1, when the cursor snaps to the intersection, click to locate the center of the circle.
   - Move the cursor away from the center and click X2 to complete the circle.
   - Middle-click in the graphics area to deselect the circle tool.
2. Changing the circle diameter:
   • Double-click the diameter dimension value at X1, then type 8 and press ENTER.

![Image of a circle being modified](image)

Depending on how large your circle was first sketched, the resized circle may appear very small within the graphics area. This is common for the first sketch created in a new model and as you will see, it is nothing to worry about.

3. Refitting the sketch in the graphics area.
   • In the Graphics toolbar click Refit to refit the sketch within the graphics area.

![Image of refitting the sketch](image)

4. Click OK from the Close group of the Sketch tab to complete the sketch and return to the Extrude dashboard.

What have you learned?

• Sketch – Circle (center and point on circle).
• Dimensions – Changing value, lock.
Step 4: Complete the Extrude that defines the length of the strut

You will now edit the depth of the Extrude to be 90, extruded symmetrically on both sides of the sketch plane.

1. Making changes to the extrude using the dashboard:
   • Click Blind and then select Symmetric from the depth drop-down menu (shown as X1).
   • Click in the depth field X2, type 90 and press ENTER.
   • Click Complete Feature from the dashboard.
   • In the Graphics toolbar click Refit to refit the model within the graphics area.

2. Saving your work:
   • In the Quick Access toolbar, click Save to save your work.
   • In the Save Object dialog, click OK to specify that the model will be saved to your working directory.

What have you learned?

- Extrude - sketch based feature, to a depth, symmetrical.
- Dashboard interface.
- Saving the current model.
Step 5: Extrude shoulder geometry

You will use the same technique used in Step 4 to extrude a 12 mm diameter circle sketched on the datum plane RIGHT. This feature will have a depth of 70 mm, extruded symmetrically from both sides of the sketch plane. This will form the shoulder of the strut.

1. If necessary, disable the display of all datum features except datum planes.

2. Reorienting the model to its default orientation:
   - Press **CTRL + D**.

3. Starting an Extrude feature and defining the sketch plane:
   - Start the Extrude tool from the Shapes group.
   - In the model tree or graphics area, click to select datum plane RIGHT as the sketch plane.

4. With the Sketch tab now open, begin sketching a circle:
   - In the Sketch tab, click Center and Point Circle.
   - Move the cursor over the intersection of the two reference lines X1, when the cursor snaps to the intersection, click to locate the center of the circle.
   - Move the cursor away from the center and click X2 to complete the circle.
   - Middle-click in the graphics area to deselect the circle tool.
5. Changing the circle diameter:
   • Double-click the diameter dimension value at X1, then type 12 and press ENTER.

6. Completing the sketch:
   • Click OK from the Close group of the Sketch tab.

7. Disable the display of datum planes.
8. Defining the extrude to form the shoulder of the strut:

By default, Creo Parametric displays a preview of the extruded circle adding material to the right of the sketch plane. You will now use options in the dashboard to make the feature extrude 70 mm symmetrically about the sketch plane.

- Select **Symmetric** from the depth drop-down menu (shown as X1).
- Click in the depth field X2, type 70 and press ENTER.
- Click **Complete Feature**.

9. Click **Save** to save your work.

**What have you learned?**

- Datum plane - visibility.
- Viewing the model – default, spin.
- Extrude - sketch based feature, to a depth, symmetrical.
- Sketch geometry – circle, diameter dimension, locking dimensions.
- Dashboard interface.
- Saving the current model.
Step 6: Revolve a sketched arc to thin the center of the strut

You will use a Revolve feature with an arc sketch drawn on the FRONT datum plane to remove material around the centre of the strut. This will make the strut lighter and reduce the amount of material being used.

1. If necessary, disable the display of all datum features.

2. Starting a Revolve (sketch based) feature and defining the sketch plane:
   - Start the Revolve tool from the Shapes group.
   - Notice the Revolve dashboard and its revolve specific options.
   - In the model tree, click to select datum plane FRONT as the sketch plane.
   - In the Graphics toolbar, click Sketch View to reorient the sketch plane parallel to the screen.

The model space will rotate until the sketch plane is parallel to the computer screen.
The sketch you will be creating must to be snapped to the top silhouette edge of the strut. To do this, you will create geometry references on-the-fly, using the ALT key.

3. Starting an arc:
   - In the Sketch tab, select Center and Ends from the arc types drop-down menu.
   - Move the cursor until it snaps to a point X1 on the vertical reference above the strut. Click to place the center of the arc.

   - Move the cursor away from the center and you will see a construction circle previewing the size of the arc you are creating.
   - With the cursor over the top horizontal edge of the strut at X2, press the ALT key and click.
   - A light blue reference line will appear along the top edge of the strut.
   - With the cursor over the reference line, also at X2, click to locate the start point of the arc.
   - Move the cursor to the right and click on the reference at X3 to locate the endpoint of the arc.
   - Middle-click in the graphics area to deselect the arc tool.
You will now resize the arc using the mouse and then use the **Normal Dimension** tool to replace the weak dimensions Creo Parametric automatically added to your sketch with the dimensions you need to describe your design intent.

5. Dragging the arc to resize it:
   - Click to select and drag the arc until it is above the horizontal reference line as shown by **X1**, then release the mouse button to place the resized arc.

6. Dimensioning the arc:
   - If necessary, zoom in closer to the arc.
   - Click **Normal Dimension** from the Dimension group.
   - Click to select the horizontal reference line at **X1**.
   - Click the arc at **X2**.
   - Middle-click at **X3** to place the dimension value.
   - Type 4 and press **ENTER**.
• With the **Normal Dimension** still active, click the end of the arc shown at **X1**.
• Click the other end of the arc **X2**.
• Middle-click at **X3** to place the dimension value.
• Type **60** and press **ENTER**.
• Middle-click to release the dimension tool.

The dimensioned sketch should look like this.

---

**A revolved feature requires a sketched profile and an axis of revolution. You will sketch a Geometric Centerline to define the axis of revolution.**

7. **Adding a Geometric center line:**

   • Click **Geometry Centerline** from the Datum group of the Sketch tab.

     **Make sure you select the centerline tool from the Datum group, not the Sketching group.**

   • Click on the horizontal reference at **X1** to start the centerline and at **X2** to end it. Be sure both are snapped to the horizontal reference.

   • Press **CTRL + D** to reorient the model to its default orientation.
• Click OK to complete the sketch and return to the revolve dashboard.

The preview of the feature shows the dimension defining the revolve feature as 360 degrees around the axis of rotation.

8. Editing the Revolve feature to remove material from the strut:

• Click to enable the Remove Material option from the dashboard. Material will be removed from the side of the sketch shown by the yellow material direction arrow.

• Click Complete Feature.

9. Click Save to save your work.

What have you learned?

• Datum plane - visibility.
• Viewing the model – default, spin.
• Sketch – Adding new references on the fly.
• Sketch geometry – arc, geometry centre lines.
• Sketch dimensions – editing, adding new, locking.
• Revolve - sketch based feature, requires a profile and a center line.
• Revolve dashboard – create solid, remove material, preview.
• Saving the current model.
Step 7: Round edges of the strut

Smooth the edges of the strut shoulders by adding a 0.5 mm round.

1. If necessary, disable the display of all datum features and press CTRL + D to return the model to its default orientation.

Start the Round tool from the Engineering group.

2. Defining the radius of the round:
   - In the dashboard, edit radius X1 to be 0.5 and press ENTER.

3. Selecting the edges to round:
   - Select one of the edges shown in green.
   - Press CTRL and select the other edge shown in green.
   - Click Complete Feature.

4. Saving your work:
   - If necessary, press CTRL + D to reorient the model to its default orientation.
   - Click Save to save your work.

What have you learned?

- Direct feature – Round.
- Round dashboard – setting the radius.
- Selecting edge references – individual, adding reference edges using CTRL key.
- Saving the model.
Step 8: Chamfer the ends of the strut

Like rounds, chamfers are also “Direct” features and applied to edges of the model. You will add 0.5 mm chamfer to the both ends of the strut. This will make it easier to insert the strut ends into the holes of the cubes.

1. Start the Chamfer tool from the Engineering group of the Model tab.
   • Notice the Chamfer dashboard and its chamfer specific options.

2. Defining the size of the chamfer:
   • In the dashboard, edit the size of the chamfer width to be 0.5 and press ENTER.

3. Selecting edges to chamfer:
   • Select one of the edges shown in green.
   • Press CTRL and select the other edge shown in green.
   • Click Complete Feature.

4. Saving your work:
   • If necessary, press CTRL + D to reorient the model to its default orientation.
   • Click Save to save your work.

What have you learned?

- Direct feature – Chamfer.
- Chamfer dashboard – setting the width (D x D).
- Selecting edge references – individual, adding reference edges using CTRL key.
- Saving the model.
Module 3
Procedure – Assembly

Scenario

This section will teach you how to assemble the components you have created into an assembly.

You will start by creating a new assembly file. In the new assembly, you will first assemble the corner cube to the default location at the assemblies center. Struts are then assembled holes in the cube.

Once you have struts in place, additional cubes and struts can be added to the assembly.
Step 1: Set working directory and create a new assembly

If you just completed Module 2 and have not exited from Creo Parametric, tasks 1-3 below do not need to be performed, please skip to task 4.

1. Start Creo Parametric.
2. Click Close Window from the Quick Access toolbar, as many times as necessary to close all open models.
3. Setting the working directory:
   - Click Select Working Directory from the Data group of the Home tab.
   - In the Select Working Directory dialog box, browse into the folder where you saved the Corner Cube and Strut models.
   - After you have browsed into the working directory folder, click OK to set that folder as your working directory.

The assembly file you create will be saved to and opened from this “working directory”, the same folder where your Corner Cube and Strut were saved.

4. Creating the new assembly model:
   - From the Quick Access toolbar or Home tab, click New.
   - In the New dialog box, click to select Assembly as the new model type.
   - Type KIT_ASSEMBLY in the Name field and click OK.
You cannot use spaces in filenames so use underscores or hyphens instead.

5. Changing the display of datum features:
   - In the Graphics toolbar, disable the display of all datum features except coordinate systems.

The default coordinate system should be displayed at the center of the graphics area. Notice the X, Y and Z axes of the coordinate system.

What have you learned?
- Set working directory – an existing folder.
- Create a new assembly
- Datum – visibility.
Step 2: Adding the first component to the assembly

The first component you will add to the assembly is a corner cube part. The cube should be positioned using the Default constraint type. This will place the cube at the center of the assembly and make it a stable reference that other components can be assembled to.

1. Selecting the component to assemble:
   - Click Assemble \(\rightarrow\) from the Component group of the Model tab.
   - In the Open dialog box:
     - Select the CORNER_CUBE.PRT model.
     - In the lower-right corner of the dialog box, click to expand the Preview pane.
     - Click Open to assemble this component.
The part will be attached to the cursor and the Assembly dashboard will open.

2. Locating the part temporarily, before final placement:
   - Drag the corner cube just to the left of the assembly coordinate system, and then click in the graphics area to place it.

   ![At the center of the corner cube, you will see the 3D Dragger.](image)

Later, when placing components, you will use the 3D Dragger to position the component close to its final destination.

3. Adding assembly constraints:
   - In the Assembly dashboard, click Automatic and select Default from the drop-down menu.
The corner cube model is now constrained to the default center of the graphics area, where the assembly coordinate system is located.

Components change to a yellow-orange color after they have been fully constrained.

The Assembly dashboard shows the Default constraint type message confirms the part is Fully Constrained.

4. Complete the placement of the part:
   - In the Assembly dashboard, click Complete Component to complete the component placement.

5. Click Save to save your work.

What have you learned?
- Adding a component to an assembly – temporary placement.
- Assembly dashboard – status, fully constrained.
- Assembly constraints – Automatic, fully constrained.
- Datum – visibility.
Step 3: Add the first strut to the assembly

The second part you will add to the assembly is a strut part. You will position the strut by inserting the the peg at the end of the strut into a hole on the cube. Then you will mate the shoulder surface to the cube. This exactly replicates how you would assemble a strut to a cube using components.

1. Disable the display of all datum features.

2. Selecting the component to assemble:
   - Click Assemble from the Component group of the Model tab.
   - In the Open dialog box:
     - Select the STRUT_100.PRT model.
     - Click Open to assemble this component.
The part will be attached to the cursor and the Assembly dashboard will open.

3. Locating the part temporarily, before final placement:
   - Drag the strut to a position just to the right of the cube, and then click in the graphics area to place it.

   ![Diagram of part placement](image)

   If you mistakenly middle-click but do not hold down the middle-mouse button, the dashboard will close and the component placement will be prematurely completed. To re-open the dashboard and continue constraining the component, right-click the component in the model tree and select **Edit Definition** from the pop-up menu. Engineers use many shortcuts to speed up their work and middle-click is one that closes the dashboard!
Be default, the **Automatic** option is used to place components in a Creo Parametric assembly. The constraint type used is then based on the reference selected and the component location or orientation. To help with this process, try to position the component being assembled as close as you can to its final position. In the case of the strut, place it as close to the hole it will be inserted into as possible.

4. Adding the first assembly constraint:
   - Move the cursor over the cylindrical surface of the strut shown as **X1**.
   - When the cylindrical surface of the strut pre-highlights, click to select it.
   - Move the cursor over the cylindrical surface of the hole in the corner cube model, shown as **X2**.
   - When the cylindrical surface of the hole pre-highlights, click to select it.

Creo Parametric recognized the two cylindrical surfaces and applied a **Coincident** constraint to them. The peg at the end of the strut is now in line with the hole and a Coincident constraint label is displayed on the model.
5. Adding a second assembly constraint:

- Click to select the flat surface of the cube that it closest to and facing the strut $X_1$.
- Press the middle-mouse button and drag to spin the model until you can see the flat surface shown as $X_2$ on the strut.
- Click to select the flat surface shown as $X_2$.

Creo Parametric recognizes two flat surfaces facing each other and applies a **Coincident** constraint. The two selected surface are now coincident to each other.

The strut has changed to a **yellow-orange** color indicating that its position is fully constrained.
The Assembly dashboard shows the **Coincident** constraint type was the last used and that the strut is now **Fully Constrained**.

6. Click to open the **Placement** tab X1 at the left of the dashboard.
   - Notice in the Placement tab that two **Coincident** constraints were used to position the strut.
   - Typically three constraints are needed to fully constrain a component in an assembly, however, if two cylindrical surfaces or axis are made **Coincident**, the **Allow Assumptions** option X2 is enabled and it is assumed the component will not rotate about the coincident axis.

7. Click **Complete Component** to complete the component placement.
   The strut returns to its original gray color.

8. Reorienting and saving your work:
   - Press **CTRL + D** to reorient the model.
   - Click **Save**.

---

**What have you learned?**

- Datum – visibility.
- Adding a component to an assembly – temporary placement.
- Component placement – mouse/keyboard controls.
- Model tree – re-opening an entry for editing (Edit Definition).
- Assembly dashboard – status, fully constrained.
- Assembly constraints – Automatic, coincident, assumptions
- Saving the current model.
Step 4: Applying colors and textures to the parts

Creo Parametric lets you apply appearances to your model that represent a wide range of colors, textures, transparency and lighting to your models. There is also a library of predefined appearance that represent many standard materials. You will now apply appearances to the parts you created.

1. If necessary, open the KIT_ASSEMBLY.ASM model.
2. Opening the corner cube part from the assembly:
   • In the model tree, right-click CORNER_CUBE.PRT and select Open from the pop-up menu.

The corner cube part will open in a new Creo Parametric window.

3. Applying an appearance to the part:
   • Click to open the Render tab.
   • Click the Appearance Gallery text X1, just below the gray appearance ball .
   • In the My Appearances section of the dialog box, scroll X2 through the color balls until you find a color you would like to apply.
   • Click to select the color X3 you want applied to the model.

The Appearances Gallery will close and the cursor will change to a paint brush .

   • In the model tree, click the part name CORNER_CUBE.PRT; this will select the entire part.
   • Click OK in the Select dialog box or middle-click in the graphics area to apply the appearance.
The new appearance is now applied to the part.

4. Saving and closing your model:
   • Click **Save** to save your work.
   • Click **Close Window** from the **Quick Access** toolbar.

The window containing the cube will close, leaving the assembly window active.

5. Applying an appearance to the part:
   • Repeat the process, applying another appearance to the strut part.

6. Click **Close Window** from the **Quick Access** tool.
   • Notice that because Creo Parametric assemblies are associative, the new appearances are immediately displayed in the assembly. A change anywhere is seen everywhere.

**What have you learned?**

- Opening/closing a part from an assembly.
- Applying textures – Applying a default color appearance to a part.
- Saving the current model.
Step 5: Assembling more struts

1. Selecting the component to assemble:

   • Click **Assemble** ![Assemble](image) from the **Component** group.
   • In the Open dialog box, double-click the **STRUT_100.PRT** model.

   ![Component Group](image)

   Notice in the dashboard that **Place Using Interface** ![Place Using Interface](image) has been enabled and a temporary interface named **TMP_INTFC001** is selected. This means that Creo Parametric remembers the references that were selected to assemble the strut the first time so this time, they are already selected for you. You can see that the cylindrical surface of the strut is already selected.

   ![Dashboard Interface](image)

2. Locating the strut temporarily and determining which end of the strut references the second coincident constraint:

   • Drag the strut to an area above the assembly and click in the graphics area to place it.
   • Move your cursor over the **Coincident** constraint tag **X1**, the surface that is referenced by this constraint will highlight on the strut model.
   • Also notice that the **Coincident** constraint tag is pointing to the same end of the strut.

   Remember which end of the strut is highlighted, you will need to know in the task below.
3. Before selecting assembly references, use the 3D Dragger to reorient the strut:
   - Click and drag the blue ring of the 3D Dragger so that the end of the strut with the *Coincident constraint tag is facing down.
   - Click and drag near the small sphere at the center of the 3D Dragger to move the strut above the corner cube.

   **How the 3D Dragger works:**
   - Dragging an arrow moves the model along the axis of the arrow.
   - Dragging a circle rotates the model about the axis of the same colored arrow.
   - Dragging the small sphere at the center will drag the model to the same location.

4. Selecting assembly references from the corner cube:
   - Click to select the cylindrical surface of the hole X1 from the corner cube.

   The strut will shift slightly to make the two cylindrical surfaces coincident.

   - Click to select the top flat surface of the corner cube X2.

   The strut will move until the shoulder of the strut is coincident with the top of the cube and it will change to a **yellow-orange** color, indicating that it is fully constrained.
5. Click **Complete Component** to complete the placement of the second strut.

The assembly now has one corner cube and two struts.
- Continue adding struts and corners to create a larger assembly.

You do not have to create the same assembly as shown here.

You may find it useful to use the **Flip** tool from the **Placement** tab in order to flip the orientation of a constraint.

Use care to select the correct references. For example, if you select an edge rather than surface when constraining these model, you will have problems.
6. Click **Save** to save your work.

**What have you learned?**

- Assembly - adding a component, temporary placement.
- Assembly – the same constraints are offered when adding identical components, fully constrained.
- Assembly – 3D dragger to re-position the part
- Assembly - Selecting surfaces
- Saving the current model.
Module 4

Procedure - Rendering

Scenario

This section will teach you how to create a photo-realistic image of your model. This process is often called rendering.

You will start by applying a “Scene” to your model which includes details of the room, lighting and any special effects.

Creo Parametric uses these settings and calculates the light paths to create the finished image.

Step 1: Open the Render tab and apply a scene

If you just completed Module 3 and have not exited from Creo Parametric, tasks 1-4 below do not need to be performed, please skip to task 5.

1. Start Creo Parametric:
2. Click Close Window from the Quick Access toolbar, as many times as necessary to close all open models.
3. Setting the working directory:
   - Click Select Working Directory from the Data group of the Home tab.
   - In the Select Working Directory dialog box, browse into the folder where you saved the other Primer models.
   - After you have browsed into the working directory folder, click OK to set that folder as your working directory.
4. Open your assembly:
   - Click Open from the Quick Access toolbar or Home tab.
   - From the File Open dialog box, double-click your assembly to open it.
5. If necessary, disable the display of all datum features.

6. Reorient the assembly by selecting a saved view:
   - Click **Named View** from the Graphics toolbar.
   - Scroll down the list of saved views and select **TRIMETRIC**.

The assembly has been reoriented to a trimetric orientation.

If you do not see **ISOMETRIC** or **TRIMETRIC** in your named view list, either your installation of Creo Parametric has not been configured using the standard PTC Academic group. You can still zoom and spin your model into any orientation you want.

Next, you will apply one of the default scenes and corresponding room to your model. You will then snap the floor of the room to the bottom of the assembly.

7. Opening the Render tab:
   - In the Quick Access ribbon, make sure the **Render** tab is selected.
8. Applying a scene:

- In the Render ribbon, click on 📦 to open the Scene dialog box.
- Scroll through the list of scenes then double click on one to apply it to your model.
- Check/tick the **Save scene with model** option.
- In the Scenes dialog box click on the **Room** tab.

- In the **Room Orientation** section, click on ✨ the button next to the floor spin wheel. This snaps the floor to the bottom of your assembly.
- Click ✅ to finish making changes to the Scene settings.
What have you learned?

- Starting Creo Parametric
- Setting working directory – existing folder.
- Opening an existing model.
- Viewing the model – pictorial views, trimetric/isometric.
- Render toolbar.
- Scenes – applying to model, floor position,
Step 2: Draft render

Draft render will let you see whether the changes you made to the Scene settings are giving you the desired effect. Draft render doesn’t take long and gives you the opportunity to go back and quickly try out other scenes and settings.

1. Draft render:
   - In the Render toolbar, click on the draft render button to carry out a Draft render.
   - There will be a short wait with progress reported in the Render Abort dialog box.

When the draft render finishes the graphics window will display a grainy image representing the effects you have applied.
   - If you are not happy with the way your model looks, try applying a different scene.
   - Once you are happy with the draft render you can continue to refine the quality of the render.

Each time you change the scene you also need to snap the floor to the model before trying the render.

What have you learned?
   - Draft render.
   - Scenes – Applying a new scene, positioning the floor.
Step 3: Adding perspective

Perspective adds realism to the render by reducing the apparent size of objects as they get further away. An understanding of photography can help achieve the results you want.

1. Apply perspective:
   
   - In the Render ribbon, click on the Perspective Settings button.

   A default value for perspective will be applied. You will probably want to adjust the amount of perspective.
   
   - In the Render ribbon, click on Perspective to open the perspective dialog box.

   The Perspective dialog box opens.
   
   - Use the Eye distance slider combined with zooming and spinning until you see the amount of perspective you want.

2. Click OK to close the Perspective dialog box.

Here is a quick render of the perspective view.

What have you learned?

- Perspective – applying to the model, adjusting.
- Scenes – Applying a new scene, positioning the floor.
Step 4: Render setup

Render setup contains many options including the quality of the image. You will increase the quality from the default Draft setting to Maximum.

- In the Render ribbon, click on \[\text{Render Setup}\] to open the Render Setup dialog box.
- Change the Quality setting to Maximum.
- Look at the options under each of the tabs to see the wide range of settings Creo Parametric provides.
- Leave the other settings and click Close.

What have you learned?

- Render quality settings
- Brief overview of available render settings.
Step 5: Final render

- Make sure your model is in the right position.
- In the Render toolbar, click on 🎨 to carry out the final render.

The render may take some time especially on slower computers. Creo Parametric is doing a great deal of mathematical calculation to work out light paths, shadows and multiple reflections.

During the render process you may see the resolution improve a section at a time. This is a clue to the iterative calculations being carried out.

The final render should look quite realistic even with the default settings.

The level of realism is only limited by the users understanding of space, form, light, texture, and how to adjust the settings in Creo Parametric.

In the example below, additional objects have been added to create a context for the gearbox adding greatly to the realism of the scene.

What have you learned?

- Final render.
- Setting the context for render.
Module 5

Procedure - Engineering drawing

Scenario

The final section of this introductory tutorial teaches you how to create an engineering drawing from a Creo Parametric model.

This process is largely automated and, because models and drawings are “associative”, changes to the model are immediately reflected in the drawing.
Step 1: Set working directory and open cube corner

1. If necessary, start Creo Parametric:

2. Setting the working directory:
   - In the main toolbar across the top of the screen, click **File > Manage Session > Select Working Directory**.
   - In the Select Working Directory dialog box, browse to the folder where you saved your Primer models.
   - Click to select the folder.
   - Click **OK** to set the folder as your working directory.

3. Opening the cube corner part:
   - In the Quick Access menu click on 📄. The File Open dialog box opens.
     - If necessary click on **Working Directory** in the left panel.
     - Select your **Cube_corner.prt** model and click **Open**.

**What have you learned?**

- Starring Creo Parametric.
- Setting the working directory.
- Opening an existing component.
Step 2: New engineering drawing

Drawing templates in Creo Parametric will use the part open on screen as the basis for an engineering drawing. The A3/B size templates automatically create a border, title block, three orthographic views and a pictorial representation! Dimensions are easily imported from the 3D model and annotations added.

1. Starting a new drawing:
   - In the Quick Access toolbar, click on to start a new file.
   - In the New dialog box, click **Drawing** for the **Type** and type in **Corner_cube** for the **Name**.
   - The **Use default template** option should remain selected.
   - Click on **OK** and New Drawing dialog box opens.
• Leave **Use template** selected.
• Select the paper size you require, here we have chosen **a3_drawing**.
• Click **OK** to create the drawing.

![Image of template selection](image)

Depending which template you select, you will see slightly different arrangements of views.

For example the a4_drawing template has just two orthographic views.

![Image of a4_drawing template](image)

The template has saved you a great deal of work by creating borders, title blocks and the different views. Typical changes you may want to make include the scale of the drawing and adding dimensions and annotations.
What have you learned?

- Opening an existing component.
- Starting a new drawing - paper size, template.
- Automation – borders, title blocks, views.
Step 3: Changing the drawing scale

Automatic creation of the drawing will have chosen a scale to match the size of the model to the paper size. The scale is displayed below the drawing.

1. Changing the drawing scale:
   - Locate the scale display at the bottom left corner of the drawing screen and double click to open the scale dialog box.

     ![Scale Dialog Box]

   - Type a new scale then click on to to apply the new scale to the drawing.
You should always choose a scale that would be listed in a national or international standard. If Creo Parametric does not change the scale, try a different value.

What have you learned?

- Drawing scale – changing the scale.

Step 4: Moving views

By default, views are locked in position and will need to be unlocked before they can be moved.

1. Unlocking a view:
   - In the Drawing ribbon, make sure the Layout tab is selected.
   - In the drawing, click on the lower left view to select it. The view border will turn green to show it is selected.
   - Right click on the selected view and pause, from the pop-up menu, click Lock view movement to toggle the lock off.
   - The view should still be selected so move the mouse over the view and click and drag the view to a new location.

   If you are dragging the front view, you should see the other “projected” views move as you drag to keep them orthogonal.

   - When you have finished moving the views you can lock them again.

What have you learned?

- Drawing views – unlocking, moving, locking.
Step 5: Adding dimensions

There are two ways to add dimensions to a drawing.

You can “show” the dimensions used to create features in the 3D model. These have the advantage of being able to change the 3D model if they are altered in the drawing.

“Added” or “driven” dimensions can be inserted into a drawing. These report the size of the model and will update if the model changes but this type of drawing dimension cannot be used to control the 3D model.

1. Showing dimensions:
   - In the drawing ribbon make sure the Annotate tab is selected.
   - In the graphics window, select the view you want to add dimensions to. The border of the sketch will turn green showing it is selected.
   - In the Annotate ribbon, click on Show Model Annotations.

The Show Model Annotations dialog box will open listing all the dimensions that were used to create the 3D model of the corner cube.

These can be checked/ticked individually to make them appear on the drawing in the select view. Near the bottom of the dialog box is a button to add all the dimensions.

   - Click to show all dimensions on the selected view.

The dimensions will appear on the selected view but may not be placed properly.
2. Moving dimensions:
   - Click away from the model views to cancel any selections.
   - Click to select the text for one of the dimensions. The text will turn red to show it is selected.
   - Click and drag the selected text to a new location.

Here the 30mm linear dimension has been moved between the limit lines.

3. Deleting dimensions:
   Just above the cube is a 0 (zero) dimension that is not required on the drawing.
   - Click to select the dimension then press Del on the keyboard.

The dimension is removed from the drawing but will remain in the 3D model.

4. Moving dimensions to a different view:
   Some of the dimensions would be better displayed on another view.
   - Click to select the hole diameter below the front view.
   - Right click on the selected text and pause, from the pop-up menu, click Move item to View.
   - Click to select the plan view above to complete the move.
   - Move the diameter into a suitable position.

The drawing below has had all the dimensions rearranged.
What have you learned?

- Drawing dimensions – overview, showing, adding.
- Showing dimensions on a drawing view.
- Moving dimensions to another view.
- Dimensions – Repositioning text, deleting.
Step 6: Adding annotations

Annotations will complete this basic drawing. You will add your school name to the title block.

1. Adding annotation text:
   • In the Drawing ribbon the Annotate tab should be active.
   • Click on \( \text{Note} \) to begin adding a Note.

Menu Manager opens listing the default options: No Leader, Horizontal, Standard and Default (alignment). These defaults are fine for our title text.
   • At the bottom of the Menu Manager, click on Make Note.
   • Click in the middle of the large empty cell at the top of the title block to set the location for the note.
   • In the Note text entry dialog box, type the name of your school. If you want a second line of text click \( \checkmark \) or press ENTER on the keyboard.

   ![Menu Manager]

   • Click \( \checkmark \) twice or press ENTER on the keyboard twice to place the text.
   • Click on Done/Return to close the Menu Manager.

   ![Completed Title Block]

   • Select the new text and move it into position.
2. Edit annotation text:
   • Click to select the text. A green rectangle surrounds the text to show it is selected.
   • Right click on the text and, from the pop-up menu, click Properties.
   • In the Properties dialog box edit the text.
   • Click on the Text Style tab to see other parameters you can change.
   • Click OK to close the dialog box.

What have you learned?
• Adding annotations - note.
• Note text – positioning, adding text, moving, editing, formatting.
Module 6
Accreditation/optional extension task

Teachers in the UK and Australasia are required to complete a modelling task before they are issued with a school license for Creo Parametric.

- Wales - [http://www.stemcymru.org.uk/](http://www.stemcymru.org.uk/)
- Australia - nobbya@tpg.com.au
- New Zealand - h.morris@auckland.ac.nz

In other regions, teachers do not have to complete an accreditation task.

Whether this is a requirement or not, creating new components for the kit is a great way to practice your new skills with Creo Parametric. Below are some suggestions but you will probably have great ideas of your own.

Another great way to learn Creo Parametric is to model everyday objects.

Just like learning a new language or playing a musical instrument, practice is the key to becoming proficient!